using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\[|\G)\|?([^\n|\]]+)(?=[\]|])";
string input = @"[keyword1|keyword2|keyword3]
[keyword4|keyword5]
[keyword6]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}