re = /(?:^\[|\G)\|?([^\n|\]]+)(?=[\]|])/m
str = '[keyword1|keyword2|keyword3]
[keyword4|keyword5]
[keyword6]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end