re = /^\*\s+(\w\w\w-\d\d-\d\d\d\d)\s+(\w+)\s+(\d+)\s+(?!Created)/
str = '* JAN-01-2001 bugsbunny 1234 Created Module'
# Print the match result
str.match(re) do |match|
puts match.to_s
end