$re = '/^\[\d+\.(.*?)\s*\]$/s';
$str = '[1. dolor sit amet, [consectetuer adipiscing] elit.]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);