re = /^\[\d+\.(.*?)\s*\]$/
str = '[1. dolor sit amet, [consectetuer adipiscing] elit.]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end