const regex = /\$_\.getArrayInstance\((?:\[([^;]*)\]|)\);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$_\\.getArrayInstance\\((?:\\[([^;]*)\\]|)\\);', 'g')
const str = `var pdr_manager = \$_.UNINITIALIZED();
var internalWidgets = \$_.getArrayInstance();
var categorySelect= \$_.UNINITIALIZED();
var operatorMap = \$_.getArrayInstance([
'EQUAL': '='
]);
firstColumnCheckBox: \$_.getObjectInstance({
isEnabled: true,
allowMultipleSelection: true,
field: {'Select':nah},
width: 65
}),`;
const subst = `[$1];`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);