$re = '/\$_\.getArrayInstance\((?:\[([^;]*)\]|)\);/';
$str = 'var pdr_manager = $_.UNINITIALIZED();
var internalWidgets = $_.getArrayInstance();
var categorySelect= $_.UNINITIALIZED();
var operatorMap = $_.getArrayInstance([
\'EQUAL\': \'=\'
]);
firstColumnCheckBox: $_.getObjectInstance({
isEnabled: true,
allowMultipleSelection: true,
field: {\'Select\':nah},
width: 65
}),';
$subst = "[$1];";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;