# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|[a-zA-z0-9]{1,9}//g;t' <<< "|c001177ffSave Code =|r |cff00AA00A|cff00AA00G|cff00AA00Q|cffff69b4g|r |cff00AA00R|cff40e0d09|cffffff00$|cffffff00#|r |cff40e0d04|cffff69b4f|cff00AA00R"