package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\|[a-zA-z0-9]{1,9}`)
var str = `|c001177ffSave Code =|r |cff00AA00A|cff00AA00G|cff00AA00Q|cffff69b4g|r |cff00AA00R|cff40e0d09|cffffff00$|cffffff00#|r |cff40e0d04|cffff69b4f|cff00AA00R`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}