using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var\s+number\s*=\s*(\d+)\s*;";
string input = @"<script type=""text/javascript"">
var number = 100;
var foo = ""bar"";
var number=200;
var number = 500;
</script>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}