$re = '/var\s+number\s*=\s*(\d+)\s*;/';
$str = '<script type="text/javascript">
var number = 100;
var foo = "bar";
var number=200;
var number = 500;
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);