#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([+-]?\d{4}(?!\d{2}\b))((-?)((0[1-9]|1[0-2])(\3([12]\d|0[1-9]|3[01]))?|W([0-4]\d|5[0-2])(-?[1-7])?|(00[1-9]|0[1-9]\d|[12]\d{2}|3([0-5]\d|6[1-6])))([T\s]((([01]\d|2[0-3])((:?)[0-5]\d)?|24\:?00)([\.,]\d+(?!:))?)?(\17[0-5]\d([\.,]\d+)?)?([zZ]|([\+-])([01]\d|2[0-3]):?([0-5]\d)?)?)?)?$"
Local $sString = "MATCH" & @CRLF & _
"" & @CRLF & _
"2017" & @CRLF & _
"2017-06" & @CRLF & _
"2017-06-12" & @CRLF & _
"2017-06-12T10Z" & @CRLF & _
"2017-06-12T10:10Z" & @CRLF & _
"2017-06-12T10:10:15Z" & @CRLF & _
"2017-06-12T10:10:15.1Z" & @CRLF & _
"2017-06-12T10:10:15.01Z" & @CRLF & _
"2017-06-12T10:10:15.001Z" & @CRLF & _
"2017-06-12T10:10:15.770Z" & @CRLF & _
"2017-06-12T10:10:15Z" & @CRLF & _
"2017-06-12T10:10Z" & @CRLF & _
"2017-06-12T101015.770Z" & @CRLF & _
"2017-06-12T101015Z" & @CRLF & _
"2017-06-12T1010Z" & @CRLF & _
"20170612T10:10:15.770Z" & @CRLF & _
"20170612T10:10:15Z" & @CRLF & _
"20170612T10:10Z" & @CRLF & _
"20170612T101015.770Z" & @CRLF & _
"20170612T101015Z" & @CRLF & _
"20170612T1010Z" & @CRLF & _
"20170612T10Z" & @CRLF & _
"2017-06-12" & @CRLF & _
"2017-06-12T" & @CRLF & _
"1994-11-05T08:15:30-05:00" & @CRLF & _
"1994-11-05T08:15:30-0500" & @CRLF & _
"1994-11-05T08:15:30-05" & @CRLF & _
"2017-06-12T09:37:45+00:00" & @CRLF & _
"2017-06-12T09:37:45Z" & @CRLF & _
"20170612T093745Z" & @CRLF & _
"" & @CRLF & _
"DONT MATCH" & @CRLF & _
"" & @CRLF & _
"2017-06-12T24:61:61.770Z" & @CRLF & _
"2017-06-12Z" & @CRLF & _
"2017-06-12TZ" & @CRLF & _
"2017-06-12T101015770Z" & @CRLF & _
"2017-06-12T009:307:405Z" & @CRLF & _
"2017-06-12T09.37.45Z" & @CRLF & _
"2017-0612T10:10:15.770Z" & @CRLF & _
"2017-0612T10:10:15Z" & @CRLF & _
"2017-0612T10:10Z" & @CRLF & _
"2017-0612T101015.770Z" & @CRLF & _
"2017-0612T101015Z" & @CRLF & _
"2017-0612T1010Z" & @CRLF & _
"2017-0612T10Z" & @CRLF & _
"201706-12T10:10:15.770Z" & @CRLF & _
"201706-12T10:10:15Z" & @CRLF & _
"201706-12T10:10Z" & @CRLF & _
"201706-12T101015.770Z" & @CRLF & _
"201706-12T101015Z" & @CRLF & _
"201706-12T1010Z" & @CRLF & _
"201706-12T10Z" & @CRLF & _
"" & @CRLF & _
"EXTERNAL" & @CRLF & _
"MATCH" & @CRLF & _
"" & @CRLF & _
"2009-12T12:34" & @CRLF & _
"2009" & @CRLF & _
"2009-05-19" & @CRLF & _
"2009-05-19" & @CRLF & _
"20090519" & @CRLF & _
"2009123" & @CRLF & _
"2009-05" & @CRLF & _
"2009-123" & @CRLF & _
"2009-222" & @CRLF & _
"2009-001" & @CRLF & _
"2009-W01-1" & @CRLF & _
"2009-W51-1" & @CRLF & _
"2009-W511" & @CRLF & _
"2009-W33" & @CRLF & _
"2009W511" & @CRLF & _
"2009-05-19" & @CRLF & _
"2009-05-19 00:00" & @CRLF & _
"2009-05-19 14" & @CRLF & _
"2009-05-19 14:31" & @CRLF & _
"2009-05-19 14:39:22" & @CRLF & _
"2009-05-19T14:39Z" & @CRLF & _
"2009-W21-2" & @CRLF & _
"2009-W21-2T01:22" & @CRLF & _
"2009-139" & @CRLF & _
"2009-05-19 14:39:22-06:00" & @CRLF & _
"2009-05-19 14:39:22+0600" & @CRLF & _
"2009-05-19 14:39:22-01" & @CRLF & _
"20090621T0545Z" & @CRLF & _
"2007-04-06T00:00" & @CRLF & _
"2007-04-05T24:00" & @CRLF & _
"2010-02-18T16:23:48.5" & @CRLF & _
"2010-02-18T16:23:48,444" & @CRLF & _
"2010-02-18T16:23:48,3-06:00" & @CRLF & _
"2010-02-18T16:23.4" & @CRLF & _
"2010-02-18T16:23,25" & @CRLF & _
"2010-02-18T16:23.33+0600" & @CRLF & _
"2010-02-18T16.23334444" & @CRLF & _
"2010-02-18T16,2283" & @CRLF & _
"2009-05-19 143922.500" & @CRLF & _
"2009-05-19 1439,55" & @CRLF & _
"" & @CRLF & _
"DONT MATCH" & @CRLF & _
"" & @CRLF & _
"200905" & @CRLF & _
"2009367" & @CRLF & _
"2009-" & @CRLF & _
"2007-04-05T24:50" & @CRLF & _
"2009-000" & @CRLF & _
"2009-M511" & @CRLF & _
"2009M511" & @CRLF & _
"2009-05-19T14a39r" & @CRLF & _
"2009-05-19T14:3924" & @CRLF & _
"2009-0519" & @CRLF & _
"2009-05-1914:39" & @CRLF & _
"2009-05-19 14:" & @CRLF & _
"2009-05-19r14:39" & @CRLF & _
"2009-05-19 14a39a22" & @CRLF & _
"200912-01" & @CRLF & _
"2009-05-19 14:39:22+06a00" & @CRLF & _
"2009-05-19 146922.500" & @CRLF & _
"2010-02-18T16.5:23.35:48" & @CRLF & _
"2010-02-18T16:23.35:48" & @CRLF & _
"2010-02-18T16:23.35:48.45" & @CRLF & _
"2009-05-19 14.5.44" & @CRLF & _
"2010-02-18T16:23.33.600" & @CRLF & _
"2010-02-18T16,25:23:48,444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")