# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([+-]?\d{4}(?!\d{2}\b))((-?)((0[1-9]|1[0-2])(\3([12]\d|0[1-9]|3[01]))?|W([0-4]\d|5[0-2])(-?[1-7])?|(00[1-9]|0[1-9]\d|[12]\d{2}|3([0-5]\d|6[1-6])))([T\s]((([01]\d|2[0-3])((:?)[0-5]\d)?|24\:?00)([\.,]\d+(?!:))?)?(\17[0-5]\d([\.,]\d+)?)?([zZ]|([\+-])([01]\d|2[0-3]):?([0-5]\d)?)?)?)?$"
test_str = ("MATCH\n\n"
"2017\n"
"2017-06\n"
"2017-06-12\n"
"2017-06-12T10Z\n"
"2017-06-12T10:10Z\n"
"2017-06-12T10:10:15Z\n"
"2017-06-12T10:10:15.1Z\n"
"2017-06-12T10:10:15.01Z\n"
"2017-06-12T10:10:15.001Z\n"
"2017-06-12T10:10:15.770Z\n"
"2017-06-12T10:10:15Z\n"
"2017-06-12T10:10Z\n"
"2017-06-12T101015.770Z\n"
"2017-06-12T101015Z\n"
"2017-06-12T1010Z\n"
"20170612T10:10:15.770Z\n"
"20170612T10:10:15Z\n"
"20170612T10:10Z\n"
"20170612T101015.770Z\n"
"20170612T101015Z\n"
"20170612T1010Z\n"
"20170612T10Z\n"
"2017-06-12\n"
"2017-06-12T\n"
"1994-11-05T08:15:30-05:00\n"
"1994-11-05T08:15:30-0500\n"
"1994-11-05T08:15:30-05\n"
"2017-06-12T09:37:45+00:00\n"
"2017-06-12T09:37:45Z\n"
"20170612T093745Z\n\n"
"DONT MATCH\n\n"
"2017-06-12T24:61:61.770Z\n"
"2017-06-12Z\n"
"2017-06-12TZ\n"
"2017-06-12T101015770Z\n"
"2017-06-12T009:307:405Z\n"
"2017-06-12T09.37.45Z\n"
"2017-0612T10:10:15.770Z\n"
"2017-0612T10:10:15Z\n"
"2017-0612T10:10Z\n"
"2017-0612T101015.770Z\n"
"2017-0612T101015Z\n"
"2017-0612T1010Z\n"
"2017-0612T10Z\n"
"201706-12T10:10:15.770Z\n"
"201706-12T10:10:15Z\n"
"201706-12T10:10Z\n"
"201706-12T101015.770Z\n"
"201706-12T101015Z\n"
"201706-12T1010Z\n"
"201706-12T10Z\n\n"
"EXTERNAL\n"
"MATCH\n\n"
"2009-12T12:34\n"
"2009\n"
"2009-05-19\n"
"2009-05-19\n"
"20090519\n"
"2009123\n"
"2009-05\n"
"2009-123\n"
"2009-222\n"
"2009-001\n"
"2009-W01-1\n"
"2009-W51-1\n"
"2009-W511\n"
"2009-W33\n"
"2009W511\n"
"2009-05-19\n"
"2009-05-19 00:00\n"
"2009-05-19 14\n"
"2009-05-19 14:31\n"
"2009-05-19 14:39:22\n"
"2009-05-19T14:39Z\n"
"2009-W21-2\n"
"2009-W21-2T01:22\n"
"2009-139\n"
"2009-05-19 14:39:22-06:00\n"
"2009-05-19 14:39:22+0600\n"
"2009-05-19 14:39:22-01\n"
"20090621T0545Z\n"
"2007-04-06T00:00\n"
"2007-04-05T24:00\n"
"2010-02-18T16:23:48.5\n"
"2010-02-18T16:23:48,444\n"
"2010-02-18T16:23:48,3-06:00\n"
"2010-02-18T16:23.4\n"
"2010-02-18T16:23,25\n"
"2010-02-18T16:23.33+0600\n"
"2010-02-18T16.23334444\n"
"2010-02-18T16,2283\n"
"2009-05-19 143922.500\n"
"2009-05-19 1439,55\n\n"
"DONT MATCH\n\n"
"200905\n"
"2009367\n"
"2009-\n"
"2007-04-05T24:50\n"
"2009-000\n"
"2009-M511\n"
"2009M511\n"
"2009-05-19T14a39r\n"
"2009-05-19T14:3924\n"
"2009-0519\n"
"2009-05-1914:39\n"
"2009-05-19 14:\n"
"2009-05-19r14:39\n"
"2009-05-19 14a39a22\n"
"200912-01\n"
"2009-05-19 14:39:22+06a00\n"
"2009-05-19 146922.500\n"
"2010-02-18T16.5:23.35:48\n"
"2010-02-18T16:23.35:48\n"
"2010-02-18T16:23.35:48.45\n"
"2009-05-19 14.5.44\n"
"2010-02-18T16:23.33.600\n"
"2010-02-18T16,25:23:48,444")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.