$re = '/(?<!\d\d\d\s?)lt\.?\s?blue\b/m';
$str = 'ltblue
500lt.blue
4009 lt blue
lt. blue
032 lt red';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);