re = /(?<!\d\d\d\s?)lt\.?\s?blue\b/m
str = 'ltblue
500lt.blue
4009 lt blue
lt. blue
032 lt red'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end