$re = '/(\{\{(\w+):(\w+)\}\})/';
$str = 'fdfd{{dsfdss:dssssasa}} fdsfdsfds';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);