#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0|[1-9]\d{0,2})(?:\.\d{3})*(?:,\d{2})?$"
Local $sString = "Positive results" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"0,55" & @CRLF & _
"1" & @CRLF & _
"1,60" & @CRLF & _
"10" & @CRLF & _
"10,70" & @CRLF & _
"100" & @CRLF & _
"100,80" & @CRLF & _
"1,10" & @CRLF & _
"1.000" & @CRLF & _
"1.000,20" & @CRLF & _
"10.000" & @CRLF & _
"10.000,03" & @CRLF & _
"100.000" & @CRLF & _
"100.000,08" & @CRLF & _
"1.000.000.000" & @CRLF & _
"1.000.000.000,10" & @CRLF & _
"" & @CRLF & _
"Negative results" & @CRLF & _
"" & @CRLF & _
"0,0" & @CRLF & _
"1,1" & @CRLF & _
"1,000" & @CRLF & _
"1000.000" & @CRLF & _
"1.000,1" & @CRLF & _
"1.000,100" & @CRLF & _
"1.0,00" & @CRLF & _
"1.00,00" & @CRLF & _
"1.000,0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")