$re = '/^(?:0|[1-9]\d{0,2})(?:\.\d{3})*(?:,\d{2})?$/m';
$str = 'Positive results
0
0,55
1
1,60
10
10,70
100
100,80
1,10
1.000
1.000,20
10.000
10.000,03
100.000
100.000,08
1.000.000.000
1.000.000.000,10
Negative results
0,0
1,1
1,000
1000.000
1.000,1
1.000,100
1.0,00
1.00,00
1.000,0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);