const regex = /(http|https):\/\/[a-zA-Z][a-zA-Z0-9-.]+(:[0-9]{1,5})?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|https):\\\/\\\/[a-zA-Z][a-zA-Z0-9-.]+(:[0-9]{1,5})?', '')
const str = `http://google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}