$re = '/(http|https):\/\/[a-zA-Z][a-zA-Z0-9-.]+(:[0-9]{1,5})?/';
$str = 'http://google.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);