re = /(?<=\bopt[123]\s(?!\s*opt\d)).*?(?=\s*\bbecause_of_this\b)/m
str = 'other text opt1 opt2 opt3 I_want_only_this_text because_of_this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end