package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\|([^/]*/*[^/]*)`)
var str = `U=https://www.abcdf.com/aecb/app/login|http://llcwokhfkdvc.webs.com/sajc-services
U=http://localhost:7438/en.html|http://localhost:6148372/content/bdsajf/en/kjf-LKJf/FJKSF-cbxjs.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}