re = /\|([^\/]*\/*[^\/]*)/
str = 'U=https://www.abcdf.com/aecb/app/login|http://llcwokhfkdvc.webs.com/sajc-services
U=http://localhost:7438/en.html|http://localhost:6148372/content/bdsajf/en/kjf-LKJf/FJKSF-cbxjs.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end