package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z]+(?:[\s.]+[a-zA-Z]+)*$`)
var str = `S. Harish Kumar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}