package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\d]+)`)
var str = `test 13231 test 123123
123 asdfasdf
1a2a3 a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}