const regex = /^( +)(?=\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^( +)(?=\\S)', 'gm')
const str = `var push2
function init(){
_.some(_.any(someArray, function(val){
//do something
}));
_.some(_.any(someArray, function(val){
//do something
}));
var a
var vsdasd
}adsasd
asdasasd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}