$re = '/^( +)(?=\S)/m';
$str = 'var push2
function init(){
_.some(_.any(someArray, function(val){
//do something
}));
_.some(_.any(someArray, function(val){
//do something
}));
var a
var vsdasd
}adsasd
asdasasd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);