re = /(?(?=.*?"state":"FIXED")"a":"(.*?)"|"b":"(.*?)")/m
str = '{"b":"abc","a":"def","state":"FIXED"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end