#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([1-9][0-9]*/[1-9][0-9]*)(?!%))|((?<!/)([1-9][0-9]*%))$"
Local $sString = "1/2 " & @CRLF & _
"1/10" & @CRLF & _
"10/23" & @CRLF & _
"13/30" & @CRLF & _
"50%" & @CRLF & _
"2%" & @CRLF & _
"No matches:" & @CRLF & _
"" & @CRLF & _
"0/2" & @CRLF & _
"1/0" & @CRLF & _
"02/15" & @CRLF & _
"50" & @CRLF & _
"4" & @CRLF & _
"1/2%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")