$re = '@^(([1-9][0-9]*/[1-9][0-9]*)(?!%))|((?<!/)([1-9][0-9]*%))$@m';
$str = '1/2
1/10
10/23
13/30
50%
2%
No matches:
0/2
1/0
02/15
50
4
1/2%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);