import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\1?+#)\\d+)++$";
final String string = "#12##235\n"
+ "#123\n"
+ "#12##235\n"
+ "#1234##12###368\n"
+ "#1234##12###368####22235#####723356\n\n"
+ "#123#123#123#123\n"
+ "#\n"
+ "####\n"
+ "##123\n"
+ "#123###456\n"
+ "#123##456##789\n"
+ "##1##2\n"
+ "#1##2##2\n"
+ "#1#2\n"
+ "test ing test #1\n\n"
+ "1#1\n"
+ "1##1\n"
+ "##1##1\n"
+ "#1##1###1##2#1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}