package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<booknumber>\d+(?:\.\d+)?)\)\s+(?P<item>.*?)\s+\(\d+(?:\.\d+)?\s+Dollars\)`)
var str = `1.0) The Ugly Duckling (TUD) (10 Dollars)
1.0) Little 1 Red Riding Hood (9.50 Dollars)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}