const regex = /\s*(\}\,)[\n\s]*(\{)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(\\}\\,)[\\n\\s]*(\\{)', '')
const str = ` },
{`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);