// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*(\}\,)[\n\s]*(\{)").unwrap();
let string = " },
{";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}