$re = '/^(.*?)(?=\(|Result)/m';
$str = 'Folkestone Result
Ascot (IRE) Result
Folkestone Last (IRE) Result
Winterfall Win Result';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);