re = /^(.*?)(?=\(|Result)/m
str = 'Folkestone Result
Ascot (IRE) Result
Folkestone Last (IRE) Result
Winterfall Win Result'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end