const regex = new RegExp('<span [^>]*>(\\d+)\\D(\\d+)\\D[^<]*', 'gm')
const str = `<span class="value">
Price:<br>
<span style="color:white">23,07€ </span>
</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}