// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<span [^>]*>(\d+)\D(\d+)\D[^<]*").unwrap();
let string = "<span class=\"value\">
Price:<br>
<span style=\"color:white\">23,07€ </span>
</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}