use strict;
my $str = 'N1123456';
my $regex = qr/(\D+)(\d+)/ip;
my $subst = '$1Y$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";