import Foundation
let pattern = #"(\D+)(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"N1123456"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1Y$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)