$re = '/(?<=>)(\d+)\D(\d+)\D/m';
$str = '<span class="value">
Price:<br>
<span style="color:white">23,07€ </span>
</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);