$re = '/&(?=[^=&]+=)/';
$str = 'Id=bzat4e&Name=Gallery: Blitzer: Algebra & Trigonometry, 4e&Year=2016&Code=bzat4e&Name=Gallery: Blitzer: Algebr&rigonometry,4e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);