re = /&(?=[^=&]+=)/
str = 'Id=bzat4e&Name=Gallery: Blitzer: Algebra & Trigonometry, 4e&Year=2016&Code=bzat4e&Name=Gallery: Blitzer: Algebr&rigonometry,4e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end