$re = '/\d+\.\d+,\d+/';
$str = '1 - João da Silva número 123456 com o valor de R$:6.298,65';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);