re = /\d+\.\d+,\d+/
str = '1 - João da Silva número 123456 com o valor de R$:6.298,65'
# Print the match result
str.match(re) do |match|
puts match.to_s
end