package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*?)\]`)
var str = `[#]. [Type,' '][Problem w/ICD]['- ',Assessment][' : ',Comment][LF][LF]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}