re = /\[(.*?)\]/
str = '[#]. [Type,\' \'][Problem w/ICD][\'- \',Assessment][\' : \',Comment][LF][LF]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end