#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/quizlet.com\/(.*\/)"
Local $sString = "https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/" & @CRLF & _
"https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/" & @CRLF & _
"https://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/" & @CRLF & _
"https://quizlet.com/598598503/focus-4-unit-5-flash-cards/" & @CRLF & _
"http://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")