package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/quizlet.com\/(.*\/)`)
var str = `https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/
https://quizlet.com/598598503/focus-4-unit-5-flash-cards/
http://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}