package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^_:]+):([^_]+)`)
var str = `TEST_firstname:john_lastname:doe_age:45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}